We're updating the issue view to help you get more done.Learn more

Update Swagger to non-Scala (1.5+) version to reduce dependencies

The version of Swagger currently used has Scala dependencies which account for a large chunk of the server footprint (>20%). The newer Swagger versions are pure Java and should be much lighter weight to use. This will require upgrading to the Swagger API v 2.0 from the current 1.2 version.

Status

Assignee

DerekA

Reporter

DerekA